Sage Campus Maintenance Extending Past Agreed Schedule Causing Extended Downtime

Incident Report for Sage Publishing

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 07:15 EDT

Investigating

We are actively investigating the reason for the continued downtime beyond the scheduled Maintenance window.
Posted Jul 20, 2026 - 06:33 EDT
This incident affected: Sage Campus.